frostfs-contract/debian/rules
Dmitriy Zabolotskiy 0f86c9dc1b [#291] Debian packaging
Debian package contains compiled contracts and manifests with
corresponding directories, which will be placed into
/var/lib/neofs/contract for further usage.

Depends on neo-go package to build.

Signed-off-by: Dmitriy Zabolotskiy <d.zabolotskiy@yadro.com>
2022-11-17 16:05:45 +03:00

20 lines
433 B
Makefile
Executable file

#!/usr/bin/make -f
SERVICE = neofs-contract
export NEOGO ?= $(shell command -v neo-go)
%:
dh $@
override_dh_auto_build:
make all
override_dh_auto_install:
install -D -m 0750 -d debian/$(SERVICE)/var/lib/neofs/contract
find . -maxdepth 2 \( -name '*.nef' -o -name 'config.json' \) -exec cp --parents \{\} debian/$(SERVICE)/var/lib/neofs/contract \;
override_dh_installchangelogs:
dh_installchangelogs -k CHANGELOG.md